読者です 読者をやめる 読者になる 読者になる

べすとえふぉーと

プログラミング等のノート 

BitmessageをMacにインストールする時に注意する点

Bitmessage

Bitmessageについてはここを参照
http://www.moongift.jp/2013/04/20130408-3/

コンパイル手順はここを参照
https://bitmessage.org/wiki/Compiling_instructions

とりあえずメモ

Pythonが2.7.2だとSQLite3のバージョンが古くて動かない
  https://github.com/Bitmessage/PyBitmessage/issues/87
・Python2.7.3でも動くっぽいけど、自分は2.7.4で確認
・Qtは4.x系を使う 5 以降は動くかわかんない

大まかなインストールの順番
・Qt4をインストール
PyQtの4.10.1を python configure.py ,make , sudo make install
・sipは4.14.6を python configure.py ,make , sudo make install
・最後はpython bitmessagemain.pyで実行